The customer portal is experiencing an issue
Resolved·Full outage

The customer portal is now operational. Thank you for your patience while we worked to restore the customer portal.

Tue, Aug 5, 2025, 08:17 PM
(1 month ago)
·
Affected components
Customer Portal - orders.thebuybackplatform.com
Updates

Resolved

The customer portal is now operational. Thank you for your patience while we worked to restore the customer portal.

Tue, Aug 5, 2025, 08:17 PM

Identified

We have identified an issue that is preventing users from accessing the customer portal. Our team is aware and working on a solution.

Tue, Aug 5, 2025, 07:10 PM(1 hour earlier)
Powered by